Broker offline after hanging on database update

.rpt Inspector Online Broker Version:


Please tell us about your environment where the Broker is running:

  • Operating System:
    Windows [7|8|8.1|10]
    Windows 10
  • Is this running in a virtual machine:
    Yes / No
    • If answered yes above, which virtual machine environment and version:

Please tell us about your environment where the Web Browser is running:

  • Operating System:
    Windows [7|8|8.1|10]|Linux (distro and version)|OSX 10.x

  • Browser kind and version:
    Firefox XX | Chrome XX
    Firefox 83.0 (32-bit); Microsoft Edge Version 87.0.664.57 (Official build) (64-bit)

  • Crystal Reports version:
    Crystal Reports [2016 / 14.2.x|2013 / 14.1.x|2011 / 14.0.x|2008 / 12.x.x|XI R2 / 11.5.x|XI / 11.x.x|10.x.x|9.x.x|8.5.x]

Current behavior:

I am unable to consistently process a batch of reports. If I load more than 50 reports the processing window never displays that the reports are being processed and no reports are processed.

If I load 50 or less reports then the process window will display processing activity and reports are processed, but yesterday it hung displaying the final report in the batch for over an hour. I finally logged out of .rpt Inspector, and now every time I log back in I am told that the Broker is not running.

I see form an earlier report that this could indicate a unexpired session. Is there some way to expire it?


Expected behavior:

Load fifty reports
Select all fifty reports
Select Change Database Source and supply credentials
Wait to see if processing windows hangs on the last report
If it does, log out of .rpt Inspector Online.
Log out of broker
Log back in
Receive Broker is Offline Dialog

@mbrook sorry to hear that you’re having issues. This type of issue is often user environment specific and can depend on multiple factors. We are able to easily add hundreds and even thousands of reports at a time without issue.

  1. Have you ever been able to add more than 50 reports successfully in the past?
  2. Are you always adding the same set of 50+ reports? It’s possible that one or more of those report(s) is causing an error that’s preventing it to continue? For example, are you able to add the report in your screenshot directly by itself without issue?

I’ve cleared out your sessions. Please be sure to logout and close the broker, as well as the browser and then open the broker again, login then, then do the same with the browser - in that order.

Also, though it may not help you now, just to share, there are multiple improvements we are also making to the broker so that it works better in firewall / proxy environments which sometimes get in the way and continue to improve its reliability and performance, and is more resilient with the sessions.

Thank you very much.

Unfortunately, I neglected to log-out of the portal before reopening the broker and it still hung. Can you clear the sessions for me again. I have now logged out of both the portal and the broker.

I have been able to verify that report in the screenshot (45 of 45) was not processed. I will test it by itself once I can connect.

I have never been able to process large batches, but I do not need to change the data source all that often. I will try it on a remote computer with no VPN activated in order to by-pass the corporate firewall and see it that allows for a larger batch. It would be nice–I have 1400 reports to change.

Sessions cleared out again. Please try once again. If you’re still having issues, please let us know and we’ll schedule a screen sharing session to assist further.

Broker still will not connect. I did have a VPN connected when I first tried, but I have now shut that off. Would you like to reset the session one more time or arrange a screen share?

Sessions cleared out again.

I still cannot get the app to recognize the that the broker is running. I have uninstalled and reinstalled the broker, rebooted, made sure there was no active VPN connection, and also tried running it on a computer behind the corporate firewall (where I have successfully run it in the past) via an RDP session. This was working on Tuesday and up to a point on Wednesday, when it hung.

Please review the DM just sent you with details on proceeding with a screen share session so that we can assist you further and get you back to working again.