Broker 0.6.1 unable to logout

.rpt Inspector Online Broker Version:
Broker 0.6.1

Please tell us about your environment where the Broker is running:

  • Operating System:
    Windows 10

Please tell us about your environment where the Web Browser is running:

  • Operating System:
    Windows 10

  • Browser kind and version:
    Chrome 63.0.3239.132 (Official Build) (64-bit)

  • Crystal Reports version:
    Crystal Reports – Business Object 10 R2

Current behavior:

Expected behavior:
Installed new version and when tried to logout of broker just does nothing. Fails like non-connected and never logs out. When I force kill and restart all was fine until tried to login to online tool. It now reports, Another browser is already connect. Please logout of other browser.

Thank you for reporting this.

The Another browser has already connected message is displayed when you try to login another browser when one is already logged it. The browser logs in to the server, not the broker so even if the broker isn’t running you can be logged in on the browser - at which point it will show you a message that it’s waiting for you to start the broker.

But we’ll investigate the broker logout issue. @petergruenbeck have you also experienced not being able to logout of 0.6.1 broker?

Yes, the when I tried to logout of the broker last night it would not logout. So I pugged in a network cable to the laptop and seemed once the network came online then after 10 - 15 minutes the logged out notification would appear.

Sounds like you may have had a network connectivity issue then. We’ve tried to reproduce on Windows 7, 8.x, and 10 without success. Each time the logout message appeared successfully and quickly.

Haven’t been able to reproduce this or received any additional reports of this. Marking this as solved. If it happens again, please keep track of the steps. For now will chalk this up to lost network connectivity since it did show the logout when you reconnected.