Broker app crashes on upload of any report

Please tell us about your environment where the Broker is running:

  • Operating System:
    Windows [10]

  • Is this running in a virtual machine:

Please tell us about your environment where the Web Browser is running:

  • Operating System:
    Windows [10]

  • Browser kind and version:
    Chrome 70.0.3538.77 (Official Build) (64-bit)

  • Crystal Reports version:
    Crystal Reports [14.1.1]

Current behavior:

When attempting to upload RPT files, the broker crashes. I need to reopen the broker app, and it asks me to log in again.

Expected behavior:

When attempting to upload RPT files, success.

@Primordial we’ve just released an update to the broker: .rpt Inspector Online - Broker 0.6.6 released

This version may take a little longer to install than previously as in addition to the fix for the crash and several enhancements since the previous release – this new version also has new minimum requirements for the SAP Crystal Reports .NET Runtime and the Microsoft .NET Framework as detailed in the changes for the new version.

Please do let us know if it does in fact resolve your issue.

This has indeed solved the issue!

Thanks very much for the quick response.


  1. Which Windows 10 build is this?
  2. In your add/remove programs, can you take a screenshot of the installed Crystal Reports runtime to ensure that the correct one is there that is required by .rpt Inspector broker.
  3. How many reports are you able to open before this happens?
  4. Does it crash on a particular report each time? If yes, can you send us a copy of that report without data so we can examine why it’s crashing on it?
  1. Windows 10 Pro 10.0.17134 Build 17134
  2. 2018-11-07_9-13-05
  3. Immediately - every report I try to upload. I have also tried uploading a completely empty report with a basic Excel datasource, and it still fails.
  4. OK

@Primordial thank you for the additional details and sample report you sent us.

I can confirm that we’ve been able to reproduce the issue on the same Windows 10 version and build. Though it appears to work just fine on a Windows 7 system. We’re investigating this further.

Great, thanks for the update, and best of luck narrowing down the cause.